No textNo textNo text

Question about editing

Coin Toss's avatar - shape barbed.jpg
Coin Toss

Not a suggestion, just a question....

When editing a poast, and then submitting it, what was originally this (*** represents text):

 ***********

***********

***********

turns into this:

************

 

 

************

 

 

*************

 

So the question is why the huge gaps in the spacing? 

Todd's avatar - Cylon 2.gif
Todd

<Moved to Lottery Discussion forum>

Please post in the appropriate forum ... thank you.

four4me's avatar - gate1
four4me
In response to Coin Toss

Coin -------- Did you copy and paste it from some other place if you did then it will sometimes leave double spaces. If you want to paste something and not have it spaced look at the three clipboards in the editor one says paste.... one says past as plain text.... and one says paste from word experiment wit these when you post something from another place. i am referring to the rich text editor i don't use the simple editor anymore. 

Todd's avatar - Cylon 2.gif
Todd
In response to Coin Toss

I've seen that from a couple of people, but I have never been able to reproduce it myself.  If you can provide some specifics it would help.  Need to know your exact setup - OS, browser, and version numbers.  As Four4me said, I also need to know how the text got there (did you type it?) and which editor do you use.  And an exact scenario (step 1, step2, etc.).

Avatar
KY Floyd

Step 1: type something and then

 

start a new paragraph(s).  Post the reply.

 

Step 2: Go back and edit the reply, then save the changes: 

Edit starts here. Because this paragraph was started in the edit it should show up with the normal line spacing. That's also a workaround: if you delete the <enter>s and then hit enter again during the edit you'll get normal line spacing. Whatever is happening adds an extra line when the edit is saved. If you edit twice you'll add another line between paragraphs.

Windows XP SP2, Netscape 7.1 

Avatar
KY Floyd

BTW, that last post was all typed, with no cutting and pasting.

 

 

 

 

 

 

 

Here's another paragraph, to show what happens if I edit  multiple times.

I clicked edit and saved the changes twice without  actually making any changes. This paragraph was added during the third edit, and should have normal spacing. 

Todd's avatar - Cylon 2.gif
Todd

Para 1

 

Para 2

 

*Post**Edit**Still Looks The Same, edit again*

 

Must be a browser issue, because I've edited this four times with no issue.  Maybe a Netscape problem.

Editing with Netscape 9. 

Todd's avatar - Cylon 2.gif
Todd

Yup, it's a Netscape thing.  Maybe Firefox too.

line 2. 

line 3. 

Opera. 

Safari. 

Avatar
KY Floyd

Slight correction. Editing doesn't simply add an extra <enter>. It duplicates all of the existing <enter>s, which makes it exponential. The post above started with one line between paragraphs. The first edit doubled that to two, the second edit doubled it to 4 and the third edit doubled it again, to 8.

I don't know what OS and browser Coin Toss is using, but if this only affects the few of us that are still using old browsers  (or only affects a few of us for whatever odd reason) I wouldn't worry about it. It's not a real problem, and the workaround is easy, as long as you remember to do it.

Todd's avatar - Cylon 2.gif
Todd

OK, I think I may have fixed the glitch.  I tested in IE7, Netscape 9, and Firefox 2.  I'll probably hit Opera and Safari too, but I'll assume for now they're good too.

Coin Toss's avatar - shape barbed.jpg
Coin Toss

Windows XP and whatever the latest update to Mozilla Firefox is....

I'll post this, then edit, as a test..... 

Edited, now I'll click Save Changes... 

Looks like you fixed it, Todd

Smile

Tenaj's avatar - michellea
Tenaj

I had the same problem

I copied and pasted this from Word 2007, using lastest updated version of Firefox, Windows XP

 

THIS is how it looks - copied single spaced WORD 2007 using this icon

 

All cows eat grass

Get big ducks fly away

Every good boy does fine

I think maybe whether it's a paragraph or single spacef getd lost in translation when coming from Word 2007.

THIS IS PLAIN TEXT - still using single space from Word 2007 it's single space and the result I want

All cows eat grass
Get big ducks fly away
Every good boy does fine

Looks like it's the plain text that works for me 

 

This gives me the error message that using Mozilla/Firefox is not available

Posting tables is the biggy for me and it's the plain text that works for me.

182 182
071 205
960 328
859 441
748 564
637 687
526 700
415 823
304 946
293 069
182 182


Now I will type the sentences in to see, hitting enter after each line

Every good boy does fine

Great big ducks fly away

All cows eat grass

hmmmm 

What do I need to do to type in single space?  

Todd's avatar - Cylon 2.gif
Todd

@Janet:  There is nothing unique about the Lottery Post editor.  In fact, the editor I use is considered one of the best in the web development business. 

The abilities of specific brands of web browsers (such as Firefox), as well as the specific keystrokes to perform particular actions, are part of the browser software itself, and not something I control.

Understanding these things may answer some basic questions you may have.

Then, to your specific question about single-spacing:  Simply hold the Ctrl key while pressing Enter.  Doing so will insert a simple linebreak, rather than a paragraph break.  Again, this is a standard convention, not something unique to Lottery Post.

The fact that Firefox cannot handle certain functions is a limitation of the Firefox web browser.  If there is something you need to do, and Firefox can't handle it, then I would suggest the following options:

  • My #1 recommendation is to use IE7, which is the browser I test the site for most stringently, since it is the web browser most people use. 
  • Try installing Opera 9.25 (or later).  (www.opera.com)  Opera is a very good, very fast alternative web browser, and they have made great strides with compatibility.
  • Try installing Safari 3.0.4 (or later).  (www.apple.com/safari)  Apple created a Windows version of their Safari web browser, and it is pretty good, but not perfect.  If you like the Mac OS X interface, you will like Safari.  There are some features of the editor which are somewhat buggy, but you may never run into those issues.  It depends on what you do.  It wouldn't hurt to try it.
  • Try Netscape 9.x, and switch the rendering engine to IE mode.  Many people do not realize that Netscape has this capability.  By default, Netscape uses the Firefox rendering engine, but if you go into the options, you can change it to use the IE rendering engine.  It's a nice feature because you don't have to change web browsers to get the different functionality.  The downside to using Netscape is that AOL has discontinued all development on Netscape, so it is a dead-end web browser.
  • Lastly, continue using Firefox (which is a great web browser), but see if there is a different way to do the same thing.  For example, if it's a table you're using, try creating it in Excel instead of Word, and do a direct copy/paste from there.  It may work pretty well.  Also, be sure you are using the latest version of Firefox (2.0.1.12, I believe).
Tenaj's avatar - michellea
Tenaj
In response to Todd

 

Todd, thank you. Helpful information.  I think I will use your last advice on continuing using Foxfire.  I think it's almost tweaked for what works for me on this site's editor.  Even though I do have IE7.  I'm running the lastest versions of both. 

I just like Firefox because it is webmaster friendly. I am such an ignorant, inexperience webmaster that when I ran up on Firefox - I throw stones at IE7. I'm like "why doesn't Microsoft do that for us since most people use their browsers"  Go figure.  Couldn't do nothing without having to do a hack for IE.  And a dummy like me didn't know what to do in the first place, let along a hack.  And hearing the geeks argue about which hack was best made it even more confusing to me.

But I forgive IE7.  It forced me to learn stuff - epecially the old "unsecure items error" message that occurs when you have a SSL Certificate....that caused me grief.   I'll never use images again on my site coming from places like Image Shack again.  They are now on the secure directory on my server.

I've always used Ctrl/Enter as PAGE break rather than line spacing break.  Didn't know that shortcut key worked as a differently function in Editors.  A new wrinkle.

I'm going to try it here

It gave me a double space here

So I think it's all good for me now because I'm not having line spacing problems anymore when I key directly.  I let the line wrap and it did and it's single spaced - so I am good.   Thanks again.

Todd's avatar - Cylon 2.gif
Todd

Oops, it's SHIFT-Enter, not Ctrl-Enter.  Try that and you should get a single break.

Log In

Log InCancel

Forgot your username?

Forgot your password?